พบช่องโหว่ cross-site scripting บน Wordpress Plugin : Soundy Audio Playlist

เราได้รับรายงานแจ้งเตือนช่องโหว่ด้านความปลอดภัยของ Soundy Audio Playlist Plugin ช่องโหว่นี้เกิดจากการตรวจสอบความถูกต้องของอินพุตที่ผู้ใช้ให้ข้อมูลไม่ถูกต้องโดย Script ที่ชื่อว่าsoundy-audio-playlist\templates\front-end.php โดยใช้พารามิเตอร์ ‘war_sdy_pl_preview’ Hacker จะใช้ช่องโหว่นี้เพื่อแทรกสคริปต์ที่เป็นอันตรายลงในเว็บเพจซึ่งจะถูกเรียกใช้ในเว็บ และเมื่อมีการเรียกดูหน้าเว็บ Hacker จะใช้ช่องโหว่นี้ขโมยค่า Cookie สำหรับใช้ Authentication ได้

หมายเลขช่องโหว่:
CVE-2018-6001

ช่องโหว่ที่ตรวจพบ :
Cross-Site Scripting

ผลิตภัณฑ์ที่เกี่ยวข้อง :
WordPress Soundy Audio Playlist plugin for WordPress 4.6

แนวทางแก้ไข :
ไม่มีพบแนวทางการแก้ไข ตรวจสอบเมื่อวันที่ 22/01/2018