พบช่องโหว่ cross-site scripting บน Wordpress Plugin : mgl-instagram-gallery

เราได้รับรายงานแจ้งเตือนช่องโหว่ด้านความปลอดภัยของ mgl-instagram-gallery plugin ช่องโหว่นี้เกิดจากการตรวจสอบความถูกต้องของอินพุตที่ผู้ใช้ให้ข้อมูลไม่ถูกต้องโดย Script ที่ชื่อว่า single-gallery.php โดยใช้พารามิเตอร์ ‘media’ Hacker จะใช้ช่องโหว่นี้เพื่อ แทรกสคริปต์ที่เป็นอันตรายลงในเว็บเพจซึ่งจะถูกเรียกใช้ในเว็บ และเมื่อมีการเรียกดูหน้าเว็บ Hacker จะใช้ช่องโหว่นี้ขโมยค่า Cookie สำหรับใช้ Authentication ได้

หมายเลขช่องโหว่ :
CVE-2017-17869

ช่องโหว่ที่ตรวจพบ :
Cross-Site Scripting

ผลิตภัณฑ์ที่เกี่ยวข้อง :
WordPress mgl-instagram-gallery plugin for WordPress

แนวทางแก้ไข :
ไม่มีพบแนวทางการแก้ไข ตรวจสอบเมื่อวันที่ 23/12/2017