พบช่องโหว่ cross-site scripting บน Wordpress Plugin : custom-map

เราได้รับรายงานแจ้งเตือนช่องโหว่ด้านความปลอดภัยของ custom-map plugin ช่องโหว่นี้เกิดจากการตรวจสอบความถูกต้องของอินพุตที่ผู้ใช้ให้ข้อมูลไม่ถูกต้องโดย Script ที่ชื่อว่า view/advancedsettings.php  โดยใช้พารามิเตอร์ ‘map_id’ Hacker จะใช้ช่องโหว่นี้เพื่อ แทรกสคริปต์ที่เป็นอันตรายลงในเว็บเพจซึ่งจะถูกเรียกใช้ในเว็บ และเมื่อมีการเรียกดูหน้าเว็บ Hacker จะใช้ช่องโหว่นี้ขโมยค่า Cookie สำหรับใช้ Authentication ได้

หมายเลขช่องโหว่ :
CVE-2017-17744

ช่องโหว่ที่ตรวจพบ :
Cross-Site Scripting

ผลิตภัณฑ์ที่เกี่ยวข้อง :
WordPress custom-map plugin for WordPress 1.1

แนวทางแก้ไข :
ไม่มีพบแนวทางการแก้ไข ตรวจสอบเมื่อวันที่ 19/12/2017