พบช่องโหว่ cross-site scripting บน Wordpress Plugin : Emag Marketplace Connector

เราได้รับรายงานแจ้งเตือนช่องโหว่ด้านความปลอดภัยของ Emag Marketplace Connector plugin ช่องโหว่นี้เกิดจากการตรวจสอบความถูกต้องของอินพุตที่ผู้ใช้ให้ข้อมูลไม่ถูกต้องโดย Script ที่ชื่อว่า awb-meta-box.php  โดยใช้พารามิเตอร์ ‘post’ Hacker จะใช้ช่องโหว่นี้เพื่อ แทรกสคริปต์ที่เป็นอันตรายลงในเว็บเพจซึ่งจะถูกเรียกใช้ในเว็บ และเมื่อมีการเรียกดูหน้าเว็บ Hacker จะใช้ช่องโหว่นี้ขโมยค่า Cookie สำหรับใช้ Authentication ได้

ช่องโหว่ที่ตรวจพบ :
Cross-Site Scripting

ผลิตภัณฑ์ที่เกี่ยวข้อง :
WordPress Emag Marketplace Connector plugin for WordPress 1.0

แนวทางแก้ไข :
ไม่มีพบแนวทางการแก้ไข ตรวจสอบเมื่อวันที่ 21/11/2017