พบช่องโหว่ cross-site scripting บน Wordpress Plugin : Affiliate Ads for Clickbank Products

เราได้รับรายงานแจ้งเตือนช่องโหว่ด้านความปลอดภัยของ Ultimate Instagram Feed Plugin ช่องโหว่นี้เกิดจากการตรวจสอบความถูกต้องของอินพุตที่ผู้ใช้ให้ข้อมูลไม่ถูกต้องโดย Script ที่ชื่อว่า text_ads_ajax.php โดยใช้พารามิเตอร์  ‘border_color’  Hacker จะใช้ช่องโหว่นี้เพื่อ เพื่อแทรกสคริปต์ที่เป็นอันตรายลงในเว็บเพจซึ่งจะถูกเรียกใช้ในเว็บ และเมื่อมีการเรียกดูหน้าเว็บ Hacker จะใช้ช่องโหว่นี้ขโมยค่า Cookie สำหรับใช้ Authentication ได้

ช่องโหว่ที่ตรวจพบ :
Cross-Site Scripting

ผลิตภัณฑ์ที่เกี่ยวข้อง :
WordPress Affiliate Ads for Clickbank Products plugin for WordPress 1.3

แนวทางแก้ไข :
ไม่มีพบแนวทางการแก้ไข ตรวจสอบเมื่อวันที่ 14/11/2017