พบช่องโหว่ cross-site scripting บน Wordpress Plugin : Iptanus WordPress File Upload

เราได้รับรายงานแจ้งเตือนช่องโหว่ด้านความปลอดภัยของ Iptanus WordPress File Upload plugin ช่องโหว่นี้เกิดจากการตรวจสอบความถูกต้องของอินพุตที่ผู้ใช้ให้ Hacker จะใช้ประโยชน์ในส่วนของ Attribute Setting เพื่อแทรกสคริปต์ที่เป็นอันตรายลงในเว็บเพจซึ่งจะถูกเรียกใช้ในเว็บ และเมื่อมีการเรียกดูหน้าเว็บ Hacker จะใช้ช่องโหว่นี้ขโมยค่า Cookie สำหรับใช้ Authentication ได้

หมายเลขช่องโหว่:
CVE-2018-9844

ช่องโหว่ที่ตรวจพบ :
Cross-Site Scripting

ผลิตภัณฑ์ที่เกี่ยวข้อง :
WordPress Iptanus WordPress File Upload plugin for WordPress 4.3.3

แนวทางแก้ไข :
แนะนำให้อัพเดตให้เป็นเวอร์ชั่นล่าสุด ตั้งแต่ 4.3.4 ขึ้นไป