พบช่องโหว่ Component Symfony ใน Drupal

ช่องโหว่ Component Symfony เกิดจากการที่ผู้ใช้ขอเส้นทาง URL ผ่าน X-Original-URL หรือ X-Rewrite-URL ส่วนหัวของ HTTP จะอนุญาตให้ผู้ใช้เข้าถึง URL ได้โดยผ่านตัวใดตัวหนึ่ง แต่ Symfony จะส่งค่ากลับซึ่งเป็นค่าที่ต่างออกไป ซึ่งสามารถข้ามผ่านข้อจำกัดแคช และ web server ในระดับที่สูงขึ้นไป Hacker จะใช้ประโยชน์จากช่องโหว่นี้ทำการแฮ็กเว็บได้

Symfony เป็น Farmework เป็น web application ที่ประกอบด้วยชุด PHP

หมายเลขของช่องโหว่นี้คือ CVE-2018-14773 ซึ่งมีผลกระทบต่อ Drupal Core กับ Drupal เวอร์ชัน 8.5.6 ลงไป

ในตอนนี้ช่องโหว่นี้ได้รับการแก้ไขเป็นที่เรียบร้อยแล้วใน ซึ่งได้แก่ Symfony เวอร์ชั่น 7.49, 2.8.44, 3.3.18, 3.4.14, 4.0.14 และ 4.1.3 สำหรับ Drupal ได้แก้ไขปัญหานี้ในเวอร์ชันล่าสุด ซึ่งก็คือ เวอร์ชั่น 8.5.6 แล้ว

ที่มา The Hacker News